Digital Instructional Resource Issue Reported

Minor incident Digital Instructional Resources Savvas Realize
10-03-2022 01:44 PM CDT · 22 minutes

Updates

Resolved

Realize Latency

Incident resolved

Our team resolved the latency issue and Realize is operating normally.

October 3, 2022 · 02:07 PM CDT
Issue

Savvas Reporting..

Realize Latency

New incident: Investigating

We are investigating an issue that is causing some users to experience slower performance on Realize.

October 3, 2022 · 01:48 PM CDT

← Back