Skyward Running Slow

Major incident Skyward
2022-10-31 12:21 CST · 1 day, 20 hours, 15 minutes

Updates

Resolved

Skyward is now functioning properly.

November 2, 2022 · 08:36 AM CST
Issue

Skyward is running slowly.
We are working to resolve the issue as soon as possible.

October 31, 2022 · 12:25 PM CST

← Back