Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources McGraw Hill - ConnectED
01-10-2023 01:37 PM CDT · 27 minutes

Updates

Resolved

Access to McGraw Hill is back to normal.

January 10, 2023 · 02:04 PM CDT
Investigating

Access to McGraw Hill is intermittent. Getting Unable to Process request error. The company is aware of it and work in on a solution.

January 10, 2023 · 01:39 PM CDT

← Back