Slow page loads and incorrect data displayed

Minor incident Incident IQ (http://support.lisd.net)
02-07-2023 08:05 AM CDT · 4 hours, 40 minutes

Updates

Resolved

Incident IQ is reporting that this issue is resolved.

February 7, 2023 · 12:45 PM CDT
Monitoring

IIQ believes the issue has been resolved and are monitoring the results.

February 7, 2023 · 10:31 AM CDT
Issue

IIQ is experiencing some issues with the backend of their platform. Users may experience slow load times and incorrect data displayed.

February 7, 2023 · 08:06 AM CDT

← Back