Digital Instructional Resource Issue Confirmed/In Progress

Major incident Digital Instructional Resources Savvas Realize
02-10-2023 02:15 PM CDT · 30 minutes

Updates

Resolved

Savvas has corrected the issue and you should be able to access Realize now.

February 10, 2023 · 02:46 PM CDT
Issue

Users trying to access Savvas Realize will encounter an error and not be able to. Savvas is working on a resolution.

February 10, 2023 · 02:18 PM CDT

← Back