Canvas Login Issues

Minor incident Canvas
03-08-2023 08:30 AM CDT · 2 days, 4 hours, 36 minutes

Updates

Resolved

The reported issue has been resolved.

March 10, 2023 · 01:07 PM CDT
Issue

A login issue is occurring with canvas when going directly to the website. Please login to lhub.lisd.net and click on the canvas icon to sign in.

March 8, 2023 · 08:33 AM CDT

← Back