Digital Instructional Resource Issue Confirmed

Major incident Digital Instructional Resources Mindplay
04-27-2023 12:45 PM CDT · 1 day, 1 hour, 51 minutes

Updates

Resolved

The few instances that were reporting this have started working.

April 28, 2023 · 02:34 PM CDT
Issue

Users accessing Mindplay may get a license expired notice. We are aware and have contacted the vendor to find a solution.

April 27, 2023 · 12:45 PM CDT

← Back