Raptor login issues

Major incident Raptor
05-18-2023 08:11 AM CDT · 34 minutes

Updates

Resolved

Users should now be able to log in to the Raptor service.

May 18, 2023 · 08:43 AM CDT
Issue

The Raptor service is experiencing login issues. Technology is aware and investigating.

May 18, 2023 · 08:11 AM CDT

← Back