Digital Instructional Resource Issue Confirmed

Major incident Digital Instructional Resources Apex Learning
05-18-2023 11:30 AM CDT · 57 minutes

Updates

Resolved

Users can now sign into APEX.

May 18, 2023 · 12:28 PM CDT
Issue

Currently Users are not able to sign into APEX. The company is aware of the issue and is working on a fix.

May 18, 2023 · 11:30 AM CDT

← Back