Digital Instructional Resource Issue Confirmed
Major incident
Digital Instructional Resources
Explore Learning - Gizmos
08-09-2023 01:33 PM CDT
· 5 days, 21 hours, 11 minutes
Updates
Resolved
August 15, 2023 · 10:44 AM CDT
Student’s access to Gizmos should be back. Students will use the Gizmo-Student icon. Teachers can still use the original icon.
Issue
August 9, 2023 · 01:33 PM CDT
Currently there is an issue with students accessing Gizmos through Classlink app on the iPad or Safari on the iPad or computer. We have reached out to the vendor to figure out the issue.
← Back