Skyward is not working

Major incident Skyward
08-15-2023 10:48 AM CDT · 2 hours, 13 minutes

Updates

Resolved

USers should be able to sign into Skyward now. The system may run slower than normal.

August 15, 2023 · 12:59 PM CDT
Investigating

Skyward is not working at this time. It will not let you login and if you are in it is very slow. We have reached out to ISCORP to find out the issue.

August 15, 2023 · 10:48 AM CDT

← Back