Digital Instructional Resource Issue Confirmed

Minor incident Digital Instructional Resources Holt McDougal - HMH HMH - ED HMH ED - Amira
08-18-2023 10:46 AM CDT · 1 hour, 8 minutes

Updates

Resolved

HMH and Holt McDougal should be back to normal.

August 18, 2023 · 11:53 AM CDT
Issue

HMH and Holt McDougal is experiencing Service degradation. You may have a hard time signign in, or things will be slow. They are working to resolve.

August 18, 2023 · 10:46 AM CDT

← Back