Digital Instructional Resource Issue Confirmed

Minor incident Digital Instructional Resources HMH - ED HMH ED - Amira
08-24-2023 11:04 AM CDT · 1 hour, 23 minutes

Updates

Resolved

HMH is stating that all operations are back to normal.

August 24, 2023 · 12:27 PM CDT
Issue

HMH Ed is experiencing service Degradation. USers will either have issues logging in or the will experience slow loading or failed loading.

August 24, 2023 · 11:04 AM CDT

← Back