Digital Instructional Resource Issue Confirmed

Major incident Classlink SSO
08-28-2023 11:49 AM CDT · 2 hours, 1 minute

Updates

Resolved

Classlink has posted that signing in should be back to normal and the issue has been resolved.

August 28, 2023 · 01:50 PM CDT
Issue

ClassLink is reporting login issues with Launchpad. Users may recieve login error when attempting to log in. Some may experience slow loading times .

August 28, 2023 · 11:49 AM CDT

← Back