Skyward is running slow

Major incident Skyward
08-29-2023 01:08 PM CDT · 1 day, 20 hours, 53 minutes

Updates

Resolved

Skyward should be back to normal.

August 31, 2023 · 10:01 AM CDT
Monitoring

Skyward seems to be responding better now and getting back to normal.

August 29, 2023 · 01:37 PM CDT
Investigating

Skyward is currently running very slow for users. ISCORP has been notified and hopefully a fix is found quickly.

August 29, 2023 · 01:08 PM CDT

← Back