Digital Instructional Resource Issue Confirmed

Minor incident Digital Instructional Resources STEMScopes
08-31-2023 10:02 AM CDT · 1 day, 59 minutes

Updates

Resolved

The update has finished and everything should be back to normal.

September 1, 2023 · 11:00 AM CDT
Investigating

Stemscopes is running very slow due to an update that is occuring on Stemscopes side. Users may be able to get in or will get an error.

August 31, 2023 · 10:02 AM CDT

← Back