Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources Goodheart - Wilcox (GW)
09-01-2023 11:01 AM CDT · 2 hours, 3 minutes

Updates

Resolved

GW Books are showing up in the Bookself now. If you don’t have a book, clear cache and try again. Still no Book, put in a help ticket.

September 1, 2023 · 01:04 PM CDT
Investigating

GW’s bookshelves are not showing the textbooks when user try to access. GW has been contacted to find out why.

September 1, 2023 · 11:01 AM CDT

← Back