Digital Instructional Resource Issue Confirmed

Major incident Clever Digital Instructional Resources Apex Learning Everfi Explore Learning - Reflex Math ICEV Scholastic - PKOMW TCI VitalSource Wayside Publishing
09-13-2023 08:34 AM CDT · 4 hours, 58 minutes

Updates

Resolved

Issue resolved

September 13, 2023 · 01:32 PM CDT
Monitoring

Clever has said that the portal is working again and you should be able to sign in.

September 13, 2023 · 10:17 AM CDT
Issue

Clever has reported their Portal is down which is affect single sign on. It will either error out or take an extended time to get to the resource.

September 13, 2023 · 08:34 AM CDT

← Back