Digital Instructional Resource Issue Reported

Minor incident Digital Instructional Resources Discovery Education
11-15-2023 12:30 PM CDT · 2 weeks, 6 days, 2 hours, 5 minutes

Updates

Resolved

The access to DE has been fixed.

December 5, 2023 · 02:35 PM CDT
Investigating

Users at the 9th Grade campuses will get an expired account/license when trying to access Discover ED. We have reached out to the DE reps to find a resolution.

November 15, 2023 · 12:30 PM CDT

← Back