Digital Instructional Resource Issue Confirmed

Major incident Digital Instructional Resources Bedford Freeman and Worth
01-05-2024 10:51 AM CDT · 2 hours, 40 minutes

Updates

Resolved

BFW has fixed the e-book issue of not loading. Make sure student choose to continue without and account when accessing. Make sure to clear cache/history before trying.

January 5, 2024 · 01:31 PM CDT
Issue

BFW is currently having issues with many of its e-books opening when you click on the book. They are currently working on a fix.

January 5, 2024 · 10:51 AM CDT

← Back