Digital Instructional Resource Issue Confirmed

Major incident Digital Instructional Resources Bedford Freeman and Worth
01-08-2024 09:36 AM CDT · 1 day, 4 hours, 32 minutes

Updates

Resolved

BFW has said that all of the books that say were expired has been fixed. Students should now be able to access.

January 9, 2024 · 02:07 PM CDT
Investigating

Some AP Textbooks are saying that access is expired. We have reached out to BFW to find out what is happening.

January 8, 2024 · 09:36 AM CDT

← Back