Digital Instructional Resource Issue Confirmed

Minor incident Digital Instructional Resources McGraw Hill - ConnectED McGraw Hill - StudySync
01-08-2024 09:46 AM CDT · 22 hours, 54 minutes

Updates

Resolved

McGraw Hill has posted on their status page that all programs are operational.

January 9, 2024 · 08:40 AM CDT
Issue

McGraw Hill is reporting that they are having issues with their service interruption. Resoruces may or may not work.

January 8, 2024 · 09:46 AM CDT

← Back