Eduphoria Aware experiencing issues

Minor incident Eduphoria
02-01-2024 09:28 AM CDT · 2 hours, 40 minutes

Updates

Resolved

The Eduphoria Aware issues have been resolved.

February 1, 2024 · 12:08 PM CDT
Issue

Eduphoria Aware is experiencing slowness and intermittent errors. This is under investigation by Eduphoria developers.

February 1, 2024 · 09:28 AM CDT

← Back