Digital Instructional Resource Issue Confirmed
Major incident
Digital Instructional Resources
McGraw Hill - ConnectED
McGraw Hill - StudySync
03-08-2024 09:14 AM CST
· 42 minutes
Updates
Resolved
March 8, 2024 · 09:56 AM CST
McGraw Hill has posted on their status page that all systems are functioning correctly.
Issue
March 8, 2024 · 09:14 AM CST
McGraw Hill is reporting a service outage for StudySync and ConnectED. They are working on fixing.
← Back