Unable to access Eduphoria

Minor incident Eduphoria
03-26-2024 07:50 AM CDT · 1 hour, 40 minutes

Updates

Resolved

The Certificate issues for the Eduphoria website have been resolved.

March 26, 2024 · 09:28 AM CDT
Issue

Currently experiencing an issue with the Certificate for the Euphoria site. The Networking team s working to resolve the issue.

March 26, 2024 · 07:50 AM CDT

← Back