External Calling Issues

Major incident Infrastructure VoIP Phone System
04-09-2024 11:56 AM CDT · 7 hours, 33 minutes

Updates

Resolved

No additional issues reported. External calling issues are resolved.

April 9, 2024 · 07:28 PM CDT
Monitoring

External calling issues have been resolved. Monitoring will continue to help ensure there are no additional issues.

April 9, 2024 · 02:05 PM CDT
Issue

We are aware of the reported external calling issues and are working to resolve them. Updates will be provided when available.

April 9, 2024 · 11:56 AM CDT

← Back