Self Service (MDM) is offline

Major incident Self Service (MDM)
04-10-2024 08:49 AM CDT · 1 hour, 59 minutes

Updates

Resolved

Service was restored at 9:30 and appears to be stable.

April 10, 2024 · 10:48 AM CDT
Issue

Self Service (MDM) is offline. Device enrollments are unavailable. We’re working with support to restore service.

April 10, 2024 · 08:49 AM CDT

← Back