Unable to access Yuja
      
Major incident
      
        Yuja Video Platform
    
    
      
04-10-2024 10:45 AM CDT
      
      · 2 weeks, 5 days, 23 hours, 55 minutes
    
  Updates
          Update
        
        
April 19, 2024 · 10:50 AM CDT
        
      
      Users may enter their credentials manually to login to Yuja. The classlink extension that automatically enters a credential appears to be the issue.
          Issue
        
        
April 10, 2024 · 11:14 AM CDT
        
      
  Users are unable to sign in or access the Yuja video platform. Technology is working with Yuja support to restore service.
← Back
 Lewisville ISD Technology Status
            
Lewisville ISD Technology Status