Self Service (MDM) is offline.

Major incident Self Service (MDM)
04-19-2024 02:20 PM CDT · 1 week, 3 days, 20 hours, 20 minutes

Updates

Resolved

issue has been resolved

April 24, 2024 · 10:00 PM CDT
Monitoring

We’re continuing to monitor performance issues but Self Service (MDM) is currently online.

April 22, 2024 · 09:37 AM CDT
Issue

Self Service (MDM) is offline. Device enrollments are unavailable. We’re working with support to restore service.

April 19, 2024 · 02:25 PM CDT

← Back