Printers hosted on the MHS-Print server are unavailable

Major incident Printing and Document Services
05-28-2024 08:30 AM CDT · 1 day, 6 hours, 49 minutes

Updates

Resolved

We will continue to monitor performance but service has been restored.

May 29, 2024 · 03:19 PM CDT
Monitoring

A fix has been implemented. Windows users may be asked to update their Xerox driver when submitting your next print job. We will continue to monitor performance.

May 28, 2024 · 11:01 AM CDT
Issue

The MHS-Print Print server is experiencing issues. Technology is investigating.

May 28, 2024 · 09:42 AM CDT

← Back