Issues Logging into Classlink (LHUB)

Minor incident Classlink SSO
09-06-2024 09:11 AM CDT · 42 minutes

Updates

Resolved

Classlink logins should be working now.

September 6, 2024 · 09:52 AM CDT
Investigating

We are currently experiencing issues logging into Classlink. It is being investigated and we will update this page with any updates.

September 6, 2024 · 09:11 AM CDT

← Back