Canvas

Minor incident Canvas
10-17-2024 03:47 PM CDT · 22 hours, 52 minutes

Updates

Resolved

All users that use Canvas should now be able to access.

October 18, 2024 · 02:38 PM CDT
Issue

Some LISD staff that use Canvas will not be able to sign in at this time. We have contacted the vendor and they are looking into it.

October 17, 2024 · 03:47 PM CDT

← Back