Internet outage at Highland Village ES, DeLay MS, and LHS-Killough

Major incident Infrastructure Internet VoIP Phone System
10-18-2024 02:30 PM CDT · 1 hour, 15 minutes

Updates

Resolved

Fiber cut has been resolved and all campuses are operational.

October 18, 2024 · 03:45 PM CDT
Monitoring

A fiber cut has impacted three LISD campuses - Highland Village ES, DeLay MS, and LHS-Killough. UPN has been notified and the appropriate personnel are responding. We are unsure at this time of the restoration date/time. Campuses do have phone access, but calling and receiving calls will be limited.

October 18, 2024 · 02:30 PM CDT

← Back