Connectivity issues for staff and students when trying to access Canvas and Google Applications

Major incident Canvas Google
10-29-2024 09:10 AM CDT · 54 minutes

Updates

Resolved

This incident appears to be resolved. If you are still experiencing issues, please restart your device. If you continue to experience issues, please contact the LISD Helpdesk or submit a help ticket.

October 29, 2024 · 10:03 AM CDT
Investigating

We are getting reports across the district that some users are experiencing issues when trying to access Canvas as well as Google Applications. This os occurring on both MacBooks and iPads.

October 29, 2024 · 09:10 AM CDT

← Back