Incident IQ Performance Issue

Major incident Incident IQ (http://support.lisd.net)
11-12-2024 10:54 AM CST · 4 hours, 21 minutes

Updates

Resolved

Incident IQ reported the issue is resolved.

November 12, 2024 · 03:13 PM CST
Issue

Incident IQ reported a performance issue that may impact experience on the platform. Users may notice delays in loading ticket pages, performing searches, taking actions, or creating new tickets. Incident IQ is actively investigating the issue and working to resolve it as quickly as possible.

Visit the Incident IQ status page for additional details.
https://status.incidentiq.com

November 12, 2024 · 10:54 AM CST

← Back