Digital Instructional Resource Issue confirmed

Major incident Digital Instructional Resources Mindplay
11-15-2024 11:16 AM CST · 5 days, 13 hours, 42 minutes

Updates

Update

Mindplay is aware of the issue and have a site-wide issue. They are working on a fix as quickly as possible.

November 15, 2024 · 11:35 AM CST
Investigating

When users try and access Mindplay through ClassLink, they will receive an error. We are reaching out to Mindplay.

November 15, 2024 · 11:16 AM CST

← Back