IIQ is offline.
Major incident
Incident IQ (http://support.lisd.net)
12-02-2024 08:15 AM CST
· 5 hours, 25 minutes
Updates
Update
December 2, 2024 · 08:59 AM CST
IIQ support has posted the outage to their status page. You can follow updates closely here: https://status.incidentiq.com/incidents/rmr4p9jgsxs1
Issue
December 2, 2024 · 08:40 AM CST
IIQ is currently offline. We contacted vendor support and waiting for a resolution.
← Back