Digital Instructional Resource- Issue Confirmed
Major incident
Digital Instructional Resources
Apex Learning
12-06-2024 08:16 AM CST
· 11 minutes
Updates
Resolved
December 6, 2024 · 08:26 AM CST
Users can now sign into Apex. You may need to clear your history/cache and then sign in.
Investigating
December 6, 2024 · 08:16 AM CST
Users are getting error when trying to log in through LHUB and Manuel logins. We have reached out to company to find out what is happening.
← Back