Canvas - Issue Loading Quizzes

Major incident Canvas
12-06-2024 11:02 AM CST · 6 hours, 13 minutes

Updates

Resolved

Issue is resolved.

December 6, 2024 · 05:15 PM CST
Monitoring

This issue has been reported as resolved, but is still being monitored. Please refer to the site used to monitor Canvas for additional information.

https://status.instructure.com

December 6, 2024 · 04:57 PM CST
Issue

Canvas is reporting slow load times for new quizzes for users. They are currently investigating the issue.

December 6, 2024 · 11:02 AM CST

← Back