Digital Instructional Resource- Investigating
Major incident
Digital Instructional Resources
Seesaw
02-27-2025 11:03 AM CST
· 4 hours, 23 minutes
Updates
Resolved
February 27, 2025 · 03:25 PM CST
Users should now be able to access SeeSaw when going through the LHUB.
Investigating
February 27, 2025 · 11:03 AM CST
PreK Teachers that use SeeSaw through ClassLink will get an error about the server timing out. We are investigating the issue.
← Back