Self Service (MDM) is offline

Major incident Self Service (MDM)
04-15-2025 03:30 PM CDT · 16 hours, 23 minutes

Updates

Resolved

Jamf resolved their issue.

April 15, 2025 · 06:00 PM CDT
Issue

Jamf’s cloud service is experiencing an outage. Device enrollments and self service will be unavailable until their issue is resolved. More info here: https://status.jamf.com/incidents/1hxkjgbwqknq

April 15, 2025 · 03:49 PM CDT

← Back