Digital Instructional Resource Issue Confirmed

Major incident Digital Instructional Resources Apex Learning
04-21-2025 08:51 AM CDT · 46 minutes

Updates

Resolved

Users can now access Apex. Edmentum has fixed the issue and is monitoring.

April 21, 2025 · 09:37 AM CDT
Investigating

Users are not able to access Apex currently. We have reached out to Edmentum and they are investigating the issue.

April 21, 2025 · 08:51 AM CDT

← Back