Digital Resources- Issue Confirmed
Major incident
Digital Instructional Resources
Holt McDougal - HMH
05-12-2025 10:17 AM CDT
· 3 hours, 15 minutes
Updates
Resolved
May 12, 2025 · 01:32 PM CDT
Holt McDougal has corrected their issue and users should be able to get in now.
Investigating
May 12, 2025 · 10:17 AM CDT
Access ot Holt McDougal is down currently. Holt McDougal is investigating the issue. This will affect French teachers and students
← Back