Help Desk phone system offline

Minor incident Infrastructure VoIP Phone System
06-02-2025 07:22 AM CDT · 39 minutes

Updates

Resolved

Issue has been resolved

June 2, 2025 · 08:01 AM CDT
Issue

The call system used by the Technology Help Desk is currently offline. Please enter a support ticket for any issues until service is restored.

June 2, 2025 · 07:22 AM CDT

← Back