Digital Resources- Issue confirmed

Minor incident Digital Instructional Resources Apex Learning
06-03-2025 10:54 AM CDT · 1 hour, 30 minutes

Updates

Resolved

Apex has fixed the issue with users accessing. Please try accessing again. You may want to clear cache/history first.

June 3, 2025 · 12:23 PM CDT
Investigating

Users trying to access Apex are experiencing long log in times and may get error mesage. Apex is looking into it.

June 3, 2025 · 10:54 AM CDT

← Back