Temporarily Locked Out of Email Accounts

Major incident Office 365 / Staff Email
07-01-2025 09:20 AM CDT · 2 hours, 12 minutes

Updates

Resolved

The issue is being reported as resolved. We will continue to monitor and post updates if needed.

July 1, 2025 · 11:29 AM CDT
Issue

We are currently experiencing a technical issue related to the year-end rollover process that is affecting access to some mailboxes. As a result, several users may find themselves temporarily locked out of their email accounts.
Our IT team is actively working to resolve the issue, and we expect service to be fully restored within the next 1–2 hours. We understand how critical email access is and appreciate your patience and understanding as we work to resolve this as quickly as possible.
We will send a follow-up communication once the issue is fully resolved.

July 1, 2025 · 09:20 AM CDT

← Back