ClassLink- Skyward App not working

Minor incident Classlink SSO
07-15-2025 09:07 AM CDT · 6 hours

Updates

Resolved

The icon in LHUB/Classlink for Skyward is now working as it should.

July 15, 2025 · 03:07 PM CDT
Investigating

Currently the Skyward icon on the LHUB/ClassLink is not working. ClassLink is aware and is figuring out a fix. Users can go to LISD website to Resources/Families to get to Skyward. Change login area from Family/Students to All Areas

July 15, 2025 · 09:07 AM CDT

← Back