Helpdesk Phone Queue Issues

Major incident Infrastructure VoIP Phone System
07-16-2025 09:03 AM CDT · 11 minutes

Updates

Resolved

This issue appears to be resolved

July 16, 2025 · 09:15 AM CDT
Investigating

There is currently an issue with the Helpdesk phone queue. Initially callers would be notified the helpdesk was closed. Infrastructure is working on restoring call availability and the queue to normal operational status.

July 16, 2025 · 09:03 AM CDT

← Back