Access issues for Google Drive and ParentLink

Major incident Google
07-24-2025 08:46 AM CDT · 2 days, 17 minutes

Updates

Resolved

The google drive and ParentLink issue has been resolved. You should be able to access both through the LHUB now.

July 26, 2025 · 09:03 AM CDT
Issue

The Technology department has received notice that both Google Drive and ParentLink are down. The issue is being investigated. Updates will be provided as they become available.

July 24, 2025 · 08:46 AM CDT

← Back