Edgenuity is experiencing issues

Major incident Edgenuity
2020-08-20 08:49 CDT · 9 hours, 59 minutes, 9 seconds

Updates

Resolved

System is operational, please click here for Parent support Instructions

August 20, 2020 · 06:48 PM CDT
Issue

We’ve received reports from Edgenuity that they are having trouble this morning. We are working with the vendor to resolve these issues.

August 20, 2020 · 09:25 AM CDT

← Back